about summary refs log tree commit diff stats
path: root/hosts/_unmaintained/mammun/hardware/gpu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/_unmaintained/mammun/hardware/gpu.nix')
-rw-r--r--hosts/_unmaintained/mammun/hardware/gpu.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/_unmaintained/mammun/hardware/gpu.nix b/hosts/_unmaintained/mammun/hardware/gpu.nix
new file mode 100644
index 00000000..939497db
--- /dev/null
+++ b/hosts/_unmaintained/mammun/hardware/gpu.nix
@@ -0,0 +1,14 @@
+{pkgs, ...}: {
+  boot.initrd.kernelModules = ["amdgpu"];
+  # for Southern Islands (SI ie. GCN 1) cards and for Sea Islands (CIK ie. GCN 2) cards
+  boot.kernelParams = ["radeon.si_support=0" "amdgpu.si_support=1" "radeon.cik_support=0" "amdgpu.cik_support=1"];
+
+  hardware.opengl.driSupport = true;
+  # For 32 bit applications
+  hardware.opengl.driSupport32Bit = true;
+
+  hardware.opengl.extraPackages = with pkgs; [
+    rocm-opencl-icd
+    rocm-opencl-runtime
+  ];
+}