about summary refs log tree commit diff stats
path: root/hosts/_unmaintained/mammun/hardware/gpu.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 19:27:16 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 19:30:19 +0200
commitc417f127e973491b46f204e397f8152ba5d06254 (patch)
tree62f9d6986c3fc8a74d1ac8e680eb3644ce33e103 /hosts/_unmaintained/mammun/hardware/gpu.nix
parentfix(modules/legacy/conf/zsh): Move ENV-vars to their own modules (diff)
downloadnixos-config-c417f127e973491b46f204e397f8152ba5d06254.zip
refactor(hosts): Move all unmaintained hosts to the `_unmaintained` dir
Diffstat (limited to 'hosts/_unmaintained/mammun/hardware/gpu.nix')
-rw-r--r--hosts/_unmaintained/mammun/hardware/gpu.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/hosts/_unmaintained/mammun/hardware/gpu.nix b/hosts/_unmaintained/mammun/hardware/gpu.nix
new file mode 100644
index 00000000..939497db
--- /dev/null
+++ b/hosts/_unmaintained/mammun/hardware/gpu.nix
@@ -0,0 +1,14 @@
+{pkgs, ...}: {
+  boot.initrd.kernelModules = ["amdgpu"];
+  # for Southern Islands (SI ie. GCN 1) cards and for Sea Islands (CIK ie. GCN 2) cards
+  boot.kernelParams = ["radeon.si_support=0" "amdgpu.si_support=1" "radeon.cik_support=0" "amdgpu.cik_support=1"];
+
+  hardware.opengl.driSupport = true;
+  # For 32 bit applications
+  hardware.opengl.driSupport32Bit = true;
+
+  hardware.opengl.extraPackages = with pkgs; [
+    rocm-opencl-icd
+    rocm-opencl-runtime
+  ];
+}