about summary refs log tree commit diff stats
path: root/hm/soispha/conf/taskwarrior/hooks/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-01-13 11:27:01 +0100
committerSoispha <soispha@vhack.eu>2024-01-13 11:27:01 +0100
commit95c9314232bdebbff89f81ca3ab721e230290cec (patch)
tree7068a64c856ad5f655b4b12501c43b8a4711edcc /hm/soispha/conf/taskwarrior/hooks/default.nix
parentchore(version): v1.25.0 (diff)
downloadnixos-config-95c9314232bdebbff89f81ca3ab721e230290cec.zip
build(treewide): Update flake and shell library
Diffstat (limited to 'hm/soispha/conf/taskwarrior/hooks/default.nix')
-rw-r--r--hm/soispha/conf/taskwarrior/hooks/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/hm/soispha/conf/taskwarrior/hooks/default.nix b/hm/soispha/conf/taskwarrior/hooks/default.nix
index a01b1c17..4bac0ca7 100644
--- a/hm/soispha/conf/taskwarrior/hooks/default.nix
+++ b/hm/soispha/conf/taskwarrior/hooks/default.nix
@@ -31,7 +31,7 @@
   projects_comma = builtins.concatStringsSep ", " projects;
   projects_pipe = builtins.concatStringsSep "|" projects;
 
-  enforce_policies = sysLib.writeShellScriptWithLibrary {
+  enforce_policies = sysLib.writeShellScript {
     name = "bin";
     src = ./scripts/on-add_enforce-policies.sh;
     dependencies = with pkgs; [dash jq taskwarrior gnused gnugrep];
@@ -83,7 +83,7 @@
   mkSyncGitRepo = type: {
     name = "${hookPath}/${type}_sync-git-repo";
     value = {
-      source = "${sysLib.writeShellScriptWithLibrary {
+      source = "${sysLib.writeShellScript {
         name = "bin";
         src = ./scripts + "/${type}_sync-git-repo.sh";
         dependencies = with pkgs; [dash taskwarrior git];