summary refs log tree commit diff stats
path: root/modules/by-name/ga/gallery/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/ga/gallery/module.nix')
-rw-r--r--modules/by-name/ga/gallery/module.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/by-name/ga/gallery/module.nix b/modules/by-name/ga/gallery/module.nix
new file mode 100644
index 0000000..a5237e6
--- /dev/null
+++ b/modules/by-name/ga/gallery/module.nix
@@ -0,0 +1,22 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.sils.gallery;
+in {
+  options.sils.gallery = {
+    enable = lib.mkEnableOption "a stateful static gallery site";
+    domain = lib.mkOption {
+      type = lib.types.str;
+    };
+  };
+  config = lib.mkIf cfg.enable {
+    vhack.nginx.enable = true;
+    services.nginx.virtualHosts."${cfg.domain}" = {
+      forceSSL = true;
+      enableACME = true;
+      root = "/srv/${cfg.domain}";
+    };
+  };
+}