about summary refs log tree commit diff stats
path: root/tests/by-name/em/email-dns/nodes/acme/client.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-03-05 19:06:53 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-03-09 13:44:40 +0100
commitef0b3f491e1868c7b3899aff3f53be0325313c2d (patch)
tree913ddeb99ca5ce3e10f49dfe858d37780aea3c12 /tests/by-name/em/email-dns/nodes/acme/client.nix
parentpkgs/fetchmail-common-name: Patch fetchmail to accept certificates without co... (diff)
downloadnixos-server-ef0b3f491e1868c7b3899aff3f53be0325313c2d.zip
tests/email-dns: Init
This test is somewhat involved, but tries to exercise our full mail
handling capabilities.
It effectively only tests that alice can send a message to bob, but it
checks nearly all security mechanisms (DNSSEC is currently still missing).
Diffstat (limited to 'tests/by-name/em/email-dns/nodes/acme/client.nix')
-rw-r--r--tests/by-name/em/email-dns/nodes/acme/client.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/by-name/em/email-dns/nodes/acme/client.nix b/tests/by-name/em/email-dns/nodes/acme/client.nix
new file mode 100644
index 0000000..2b870e8
--- /dev/null
+++ b/tests/by-name/em/email-dns/nodes/acme/client.nix
@@ -0,0 +1,21 @@
+{
+  nodes,
+  lib,
+  ...
+}: let
+  inherit (nodes.acme.test-support.acme) caCert;
+  inherit (nodes.acme.test-support.acme) caDomain;
+in {
+  security = {
+    acme = {
+      acceptTerms = true;
+      defaults = {
+        server = "https://${caDomain}/dir";
+      };
+    };
+
+    pki = {
+      certificateFiles = lib.mkForce [caCert];
+    };
+  };
+}