about summary refs log tree commit diff stats
path: root/modules/by-name/st/stalwart-mail/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-11 11:50:13 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-23 12:10:27 +0200
commit9c4a209c50518e54fc806e2901ae7039e8826163 (patch)
tree0c99841b772ec427c9f86b4706c97466df7462a1 /modules/by-name/st/stalwart-mail/module.nix
parentmodules/stalwart-mail: Use correct group name for `redis-stalwart-mail` (diff)
downloadnixos-server-9c4a209c50518e54fc806e2901ae7039e8826163.zip
modules/stalwart-mail: Make `cfg.principals` nullable
This makes it possible to use the internal storage
Diffstat (limited to 'modules/by-name/st/stalwart-mail/module.nix')
-rw-r--r--modules/by-name/st/stalwart-mail/module.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/by-name/st/stalwart-mail/module.nix b/modules/by-name/st/stalwart-mail/module.nix
index ae3ccea..1e39e81 100644
--- a/modules/by-name/st/stalwart-mail/module.nix
+++ b/modules/by-name/st/stalwart-mail/module.nix
@@ -41,8 +41,8 @@ in {
     };
 
     principals = lib.mkOption {
-      default = [];
-      type = lib.types.listOf (lib.types.submodule {
+      default = null;
+      type = lib.types.nullOr (lib.types.listOf (lib.types.submodule {
         options = {
           name = lib.mkOption {
             type = lib.types.str;
@@ -77,7 +77,7 @@ in {
             '';
           };
         };
-      });
+      }));
     };
 
     dataDirectory = lib.mkOption {