about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-10-22 21:13:51 +0200
committerSoispha <soispha@vhack.eu>2023-10-22 21:13:51 +0200
commitfd58d11048dd6698e6116985735487d37493e67e (patch)
tree25a67c04af5a64d50abfbaf790d0c10fd365b4af /flake.nix
parentRe-removed redirect.invidious.io https://codeberg.org/LibRedirect/browser_ext... (diff)
downloadlibredirect-fd58d11048dd6698e6116985735487d37493e67e.zip
chore(treewide): Add flake and README
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 00000000..5aa629f6
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,38 @@
+{
+  description = "vhack.eu's soft fork of LibRedirect";
+
+  inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/23.05";
+
+    # inputs for following
+    systems = {
+      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
+    };
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs = {
+        systems.follows = "systems";
+      };
+    };
+  };
+
+  outputs = {
+    nixpkgs,
+    flake-utils,
+    ...
+  }:
+    flake-utils.lib.eachDefaultSystem (system: let
+      pkgs = nixpkgs.legacyPackages."${system}";
+
+    in {
+      devShells.default = pkgs.mkShell {
+        packages = [
+          pkgs.nodejs
+          pkgs.nodePackages_latest.web-ext
+          pkgs.nodePackages_latest.prettier
+        ];
+      };
+    });
+}
+# vim: ts=2
+