summary refs log tree commit diff stats
path: root/hm/ssh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/ssh/default.nix')
-rw-r--r--hm/ssh/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hm/ssh/default.nix b/hm/ssh/default.nix
new file mode 100644
index 0000000..c7b8e20
--- /dev/null
+++ b/hm/ssh/default.nix
@@ -0,0 +1,17 @@
+{...}: {
+  services.ssh-agent.enable = false;
+
+  programs.ssh = {
+    enable = true;
+    matchBlocks = let
+      genBox = user: {
+        inherit user;
+        hostname = "${user}.your-storagebox.de";
+      };
+      username = "u384702";
+    in {
+      "storagebox" = genBox username;
+      "storagebox-1" = genBox "${username}-sub1";
+    };
+  };
+}