summary refs log tree commit diff stats
path: root/rust/qmk-hid-com/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/qmk-hid-com/Cargo.toml')
-rw-r--r--rust/qmk-hid-com/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/rust/qmk-hid-com/Cargo.toml b/rust/qmk-hid-com/Cargo.toml
new file mode 100644
index 0000000..20cc11f
--- /dev/null
+++ b/rust/qmk-hid-com/Cargo.toml
@@ -0,0 +1,26 @@
+# Qmk Hid Com - A small middelware between a qmk keyboard and a wayland virtual
+# keyboard. For unicode input
+#
+# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
+# SPDX-License-Identifier: AGPL-3.0-or-later
+#
+# This file is part of Qmk Hid Com.
+#
+# You should have received a copy of the License along with this program.
+# If not, see <https://www.gnu.org/licenses/agpl.txt>.
+
+[package]
+name = "qmk-hid-com"
+description = "A small middelware between a qmk keyboard and a wayland virtual keyboard. For unicode input"
+version = "0.1.0"
+edition = "2021"
+license = "AGPL-3.0-or-later"
+homepage = ""
+repository = "https://git.foss-syndicate.org/bpeetz/tools/qmk-hid-com"
+
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[dependencies]
+anyhow = "1.0.95"
+clap = { version = "4.5.23", features = ["derive"] }
+hidapi = "2.6.3"