summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 725ac24..33ff880 100644
--- a/flake.nix
+++ b/flake.nix
@@ -44,6 +44,8 @@
       treefmtEval = import ./treefmt.nix {inherit treefmt-nix pkgs;};
 
       package = pkgs.callPackage ./package.nix {};
+
+      format_layer = pkgs.callPackage ./rust/format/package.nix {};
     in {
       packages.default = package;
       checks = {
@@ -53,8 +55,20 @@
 
       devShells.default = pkgs.mkShell {
         packages = with pkgs; [
+          format_layer
+
           reuse
           wally-cli
+          qmk
+
+          # rust
+          rustc
+          cargo
+          rustfmt
+          clippy
+          rust-analyzer
+          cargo-edit
+          cargo-expand
         ];
         env = {
           GCC_COLORS = "error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01";