summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-12-30 18:44:52 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-12-30 18:44:52 +0100
commit8beb57f19d5abd9ec9356abfc67a4da094e94b14 (patch)
tree0c041715fc5bb365729f5daff31a29bdac45d866 /flake.nix
parentfeat(treewide): Migrate the Unicode handling to a custom c program, that work... (diff)
downloadqmk_layout-8beb57f19d5abd9ec9356abfc67a4da094e94b14.zip
fix(qmk_unicode_type): Package
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 4e472d3..3880f37 100644
--- a/flake.nix
+++ b/flake.nix
@@ -46,8 +46,12 @@
       package = pkgs.callPackage ./package.nix {};
 
       format_layer = pkgs.callPackage ./rust/format/package.nix {};
+      qmk_unicode_type = pkgs.callPackage ./rust/qmk-hid-com/src_c/package.nix {};
     in {
-      packages.default = package;
+      packages = {
+        default = package;
+        inherit qmk_unicode_type;
+      };
       checks = {
         formatting = treefmtEval.config.build.check self;
       };