about summary refs log tree commit diff stats
path: root/system/services/printing/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/printing/default.nix')
-rw-r--r--system/services/printing/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/services/printing/default.nix b/system/services/printing/default.nix
new file mode 100644
index 00000000..3b193eab
--- /dev/null
+++ b/system/services/printing/default.nix
@@ -0,0 +1,19 @@
+# vim: ts=2
+{
+  config,
+  pkgs,
+  ...
+}: {
+  services.printing = {
+    enable = true;
+    webInterface = false; # don't enable the webinterface
+    drivers = with pkgs; [
+      gutenprint
+    ];
+  };
+  hardware.sane = {
+    # TODO this properly won't work like this
+    enable = true;
+    extraBackends = [pkgs.sane-airscan];
+  };
+}