about summary refs log tree commit diff stats
path: root/system/network/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/network/default.nix')
-rw-r--r--system/network/default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/system/network/default.nix b/system/network/default.nix
index b613c76a..2a68d7ce 100644
--- a/system/network/default.nix
+++ b/system/network/default.nix
@@ -1,5 +1,10 @@
 # vim: ts=2
-{config, ...}: {
+{
+  config,
+  lib,
+  ...
+}:
+{
   systemd.network = {
     networks = {
       "tap0" = {
@@ -40,3 +45,8 @@
     };
   };
 }
+// lib.mkIf config.networking.networkmanager.enable {
+  users.users.soispha.extraGroups = [
+    "networkmanager" # allows to configure networkmanager as this user
+  ];
+}