about summary refs log tree commit diff stats
path: root/system/network/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-20 07:43:36 +0200
committerSoispha <soispha@vhack.eu>2023-05-20 07:54:44 +0200
commit4d1a37c96bd5dbf31e543adad294edc0b0c3cae2 (patch)
tree6b2e8c40184f8de06af602d850b9a5eeb5910b7b /system/network/default.nix
parentFix(hm/wms/river): Remove accel from the moonlander pointer (diff)
downloadnixos-config-4d1a37c96bd5dbf31e543adad294edc0b0c3cae2.zip
Fix(system): Add configs for networkmanager only if it's enabled
Diffstat (limited to 'system/network/default.nix')
-rw-r--r--system/network/default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/system/network/default.nix b/system/network/default.nix
index b613c76a..2a68d7ce 100644
--- a/system/network/default.nix
+++ b/system/network/default.nix
@@ -1,5 +1,10 @@
 # vim: ts=2
-{config, ...}: {
+{
+  config,
+  lib,
+  ...
+}:
+{
   systemd.network = {
     networks = {
       "tap0" = {
@@ -40,3 +45,8 @@
     };
   };
 }
+// lib.mkIf config.networking.networkmanager.enable {
+  users.users.soispha.extraGroups = [
+    "networkmanager" # allows to configure networkmanager as this user
+  ];
+}