about summary refs log tree commit diff stats
path: root/system/locale/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/locale/default.nix')
-rw-r--r--system/locale/default.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/system/locale/default.nix b/system/locale/default.nix
deleted file mode 100644
index 1e7786cc..00000000
--- a/system/locale/default.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{
-  config,
-  lib,
-  ...
-}: let
-  cfg = config.soispha.locale;
-in {
-  options.soispha.locale = {
-    enable = lib.mkEnableOption (lib.mdDoc "locale");
-    keyMap = lib.mkOption {
-      type = lib.types.str;
-      example = "us";
-      default = "dvorak";
-    };
-  };
-
-  config = lib.mkIf cfg.enable {
-    # Set your time zone.
-    time.timeZone = "Europe/Berlin";
-
-    # Select internationalisation properties.
-    i18n = {
-      defaultLocale = "en_CA.UTF-8";
-      extraLocaleSettings = {
-        LANGUAGE = "en_CA:en_US:en";
-        LC_TIME = "en_DK.UTF-8";
-        LC_COLLATE = "C.UTF-8";
-      };
-    };
-
-    # Layout
-    console = {
-      inherit (cfg) keyMap;
-    };
-  };
-}