about summary refs log tree commit diff stats
path: root/system/boot/boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/boot/boot.nix')
-rw-r--r--system/boot/boot.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/system/boot/boot.nix b/system/boot/boot.nix
new file mode 100644
index 00000000..629e63ae
--- /dev/null
+++ b/system/boot/boot.nix
@@ -0,0 +1,28 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  boot = {
+    initrd = {
+      compressor = "lz4";
+      compressorArgs = ["-9"];
+    };
+
+    kernelPackages = pkgs.linuxPackages_latest;
+    loader = {
+      grub = {
+        enable = true;
+        version = 2;
+        theme = pkgs.nixos-grub2-theme;
+        splashImage = ./boot_pictures/gnu.png;
+        efiSupport = true;
+        device = "nodev"; # only for efi
+      };
+      efi = {
+        canTouchEfiVariables = true;
+        efiSysMountPoint = "/boot";
+      };
+    };
+  };
+}