about summary refs log tree commit diff stats
path: root/sys/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/default.nix')
-rw-r--r--sys/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys/default.nix b/sys/default.nix
new file mode 100644
index 00000000..e263988f
--- /dev/null
+++ b/sys/default.nix
@@ -0,0 +1,25 @@
+{lib, ...}: {
+  imports = [
+    ./boot
+    ./disks
+    ./font
+    ./hardware
+    ./impermanence
+    ./libvirtd
+    ./locale
+    ./network
+    #./nixpkgs already at flake level imported
+    ./options
+    ./polkit
+    ./power
+    ./svcs
+    ./secrets
+    ./sound
+    ./tempfiles
+    ./users # the position of this item is fully arbitrary
+  ];
+  # remove all the bloat, which nixos installs by default
+  environment = {
+    defaultPackages = lib.mkForce [];
+  };
+}