about summary refs log tree commit diff stats
path: root/services/snapper/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/snapper/default.nix')
-rw-r--r--services/snapper/default.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/services/snapper/default.nix b/services/snapper/default.nix
deleted file mode 100644
index 547ee3f5..00000000
--- a/services/snapper/default.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-# vim: ts=2
-{config, ...}: {
-  services.snapper = {
-    configs = {
-      srv = {
-        subvolume = "/srv";
-        fstype = "btrfs";
-        extraConfig = ''
-          # users and groups allowed to work with config
-          ALLOW_GROUPS="wheel"
-
-          # sync users and groups from ALLOW_USERS and ALLOW_GROUPS to .snapshots
-          # directory
-          SYNC_ACL="yes"
-
-
-          # run daily number cleanup
-          NUMBER_CLEANUP="no"
-
-          # limit for number cleanup
-          NUMBER_MIN_AGE="1800"
-          NUMBER_LIMIT="50"
-          NUMBER_LIMIT_IMPORTANT="10"
-
-
-          # create hourly snapshots
-          TIMELINE_CREATE="yes"
-
-          # cleanup hourly snapshots after some time
-          TIMELINE_CLEANUP="yes"
-
-          # limits for timeline cleanup
-          TIMELINE_MIN_AGE="1800"
-          TIMELINE_LIMIT_HOURLY="7"
-          TIMELINE_LIMIT_DAILY="3"
-          TIMELINE_LIMIT_WEEKLY="0"
-          TIMELINE_LIMIT_MONTHLY="0"
-          TIMELINE_LIMIT_YEARLY="0"
-
-
-          # cleanup empty pre-post-pairs
-          EMPTY_PRE_POST_CLEANUP="yes"
-        '';
-      };
-    };
-  };
-}