about summary refs log tree commit diff stats
path: root/services/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/nix.nix')
-rw-r--r--services/nix.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/services/nix.nix b/services/nix.nix
new file mode 100644
index 00000000..b94cfc95
--- /dev/null
+++ b/services/nix.nix
@@ -0,0 +1,18 @@
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}: {
+  nix = {
+    gc = {
+      automatic = true;
+      dates = "daily";
+      options = "--delete-older-than 3";
+    };
+    settings = {
+      auto-optimise-store = true;
+      experimental-features = ["nix-command" "flakes"];
+    };
+  };
+}