about summary refs log tree commit diff stats
path: root/pkgs/sources/yt/yts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sources/yt/yts.nix')
-rw-r--r--pkgs/sources/yt/yts.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/sources/yt/yts.nix b/pkgs/sources/yt/yts.nix
new file mode 100644
index 00000000..9a8b172e
--- /dev/null
+++ b/pkgs/sources/yt/yts.nix
@@ -0,0 +1,27 @@
+{
+  lib,
+  rustPlatform,
+  ytcc,
+  makeWrapper,
+}:
+rustPlatform.buildRustPackage {
+  pname = "yts";
+  version = "0.1.0";
+
+  src = ./.;
+  cargoLock = {
+    lockFile = ./Cargo.lock;
+  };
+
+  buildNoDefaultFeatures = true;
+  buildFeatures = ["yts"];
+
+  nativeBuildInputs = [
+    makeWrapper
+  ];
+
+  postInstall = ''
+    wrapProgram $out/bin/yts \
+      --prefix PATH : ${lib.makeBinPath [ytcc]}
+  '';
+}