about summary refs log tree commit diff stats
path: root/modules/system/laptop/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/system/laptop/default.nix')
-rw-r--r--modules/system/laptop/default.nix17
1 files changed, 0 insertions, 17 deletions
diff --git a/modules/system/laptop/default.nix b/modules/system/laptop/default.nix
deleted file mode 100644
index f70230ad..00000000
--- a/modules/system/laptop/default.nix
+++ /dev/null
@@ -1,17 +0,0 @@
-{
-  lib,
-  config,
-  ...
-}: let
-  cfg = config.soispha.laptop;
-in {
-  # TODO: Add an actual config to this module, instead of the implicit one in home manager. <2024-05-22>
-  options.soispha.laptop = {
-    enable = lib.mkEnableOption "Laptop improvements";
-    backlight = lib.mkOption {
-      type = lib.types.str;
-      example = lib.mdDoc "intel_backlight";
-      description = lib.mdDoc "Which backlight to query for the screen brightness";
-    };
-  };
-}