about summary refs log tree commit diff stats
path: root/modules/system/cleanup/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/system/cleanup/default.nix')
-rw-r--r--modules/system/cleanup/default.nix19
1 files changed, 0 insertions, 19 deletions
diff --git a/modules/system/cleanup/default.nix b/modules/system/cleanup/default.nix
deleted file mode 100644
index f8307b73..00000000
--- a/modules/system/cleanup/default.nix
+++ /dev/null
@@ -1,19 +0,0 @@
-{
-  config,
-  lib,
-  ...
-}: let
-  cfg = config.soispha.cleanup;
-in {
-  # remove all the bloat, which NixOS installs by default
-  options.soispha.cleanup = {
-    enable = lib.mkEnableOption "avoiding of nixos' default installed packages";
-  };
-
-  config = lib.mkIf cfg.enable {
-    programs.nano.enable = false;
-    environment = {
-      defaultPackages = lib.mkForce [];
-    };
-  };
-}