about summary refs log tree commit diff stats
path: root/modules/system/cleanup/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-18 17:07:46 +0200
commitc52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c (patch)
treee8b947710b467b32740598ff574982097836f66c /modules/system/cleanup/default.nix
parentchore(pkgs/yt): 1.2.1 -> 1.3.0 (diff)
downloadnixos-config-c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c.zip
refactor(modules): Move all system modules to `by-name`
From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
Diffstat (limited to 'modules/system/cleanup/default.nix')
-rw-r--r--modules/system/cleanup/default.nix19
1 files changed, 0 insertions, 19 deletions
diff --git a/modules/system/cleanup/default.nix b/modules/system/cleanup/default.nix
deleted file mode 100644
index f8307b73..00000000
--- a/modules/system/cleanup/default.nix
+++ /dev/null
@@ -1,19 +0,0 @@
-{
-  config,
-  lib,
-  ...
-}: let
-  cfg = config.soispha.cleanup;
-in {
-  # remove all the bloat, which NixOS installs by default
-  options.soispha.cleanup = {
-    enable = lib.mkEnableOption "avoiding of nixos' default installed packages";
-  };
-
-  config = lib.mkIf cfg.enable {
-    programs.nano.enable = false;
-    environment = {
-      defaultPackages = lib.mkForce [];
-    };
-  };
-}