about summary refs log tree commit diff stats
path: root/hosts/tiamat/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tiamat/hardware.nix')
-rw-r--r--hosts/tiamat/hardware.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/hosts/tiamat/hardware.nix b/hosts/tiamat/hardware.nix
deleted file mode 100644
index 2b18a662..00000000
--- a/hosts/tiamat/hardware.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-# nixos-config - My current NixOS configuration
-#
-# Copyright (C) 2025 Benedikt Peetz <benedikt.peetz@b-peetz.de>
-# SPDX-License-Identifier: GPL-3.0-or-later
-#
-# This file is part of my nixos-config.
-#
-# You should have received a copy of the License along with this program.
-# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
-{modulesPath, ...}: {
-  imports = [
-    (modulesPath + "/installer/scan/not-detected.nix") # TODO: is this necessary?
-  ];
-
-  soispha = {
-    hardware = {
-      enable = true;
-      cpuType = "amd";
-      moonlander = {
-        enableFlashing = true;
-      };
-    };
-
-    disks = {
-      enable = true;
-      disk = "/dev/disk/by-id/nvme-CT1000P5SSD8_21032C857568";
-      ssd = true;
-      swap = {
-        uuid = "057b5041-6fee-4739-84a9-ade8f0f51519";
-        resumeOffset = "533760";
-      };
-    };
-  };
-
-  boot = {
-    kernelModules = ["kvm-amd"];
-
-    kernelParams = [
-      # Avoid loosing the Bluetooth controller to a sleep, from which it never wakes again
-      "btusb.enable_autosuspend=n"
-    ];
-
-    initrd.availableKernelModules = ["nvme" "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod"];
-  };
-}