about summary refs log tree commit diff stats
path: root/hosts/tiamat/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/tiamat/configuration.nix')
-rw-r--r--hosts/tiamat/configuration.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/hosts/tiamat/configuration.nix b/hosts/tiamat/configuration.nix
new file mode 100644
index 00000000..7f68621c
--- /dev/null
+++ b/hosts/tiamat/configuration.nix
@@ -0,0 +1,21 @@
+# vim: ts=2
+{
+  config,
+  lib,
+  nixpkgs,
+  home-manager,
+  ...
+}: {
+  imports = [
+    ./hardware
+    ./networking.nix
+
+    ../../secrets
+
+    ../../system
+
+    ../../services
+  ];
+
+  system.stateVersion = "23.05";
+}