about summary refs log tree commit diff stats
path: root/hosts/by-name/apzu/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/by-name/apzu/hardware.nix')
-rw-r--r--hosts/by-name/apzu/hardware.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/hosts/by-name/apzu/hardware.nix b/hosts/by-name/apzu/hardware.nix
new file mode 100644
index 00000000..8d481fa6
--- /dev/null
+++ b/hosts/by-name/apzu/hardware.nix
@@ -0,0 +1,37 @@
+# nixos-config - My current NixOS configuration
+#
+# Copyright (C) 2025 Benedikt Peetz <benedikt.peetz@b-peetz.de>
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+# This file is part of my nixos-config.
+#
+# You should have received a copy of the License along with this program.
+# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
+{modulesPath, ...}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO: is this necessary?
+  ];
+
+  soispha = {
+    disks = {
+      enable = true;
+      disk = "/dev/disk/by-id/nvme-INTEL_SSDPEKNU512GZH_PHKA1481032A512A_1";
+      ssd = true;
+      swap = {
+        uuid = "c94cd20a-dd3c-436f-9841-6fe92e5c8719";
+        resumeOffset = "533760";
+      };
+    };
+
+    hardware = {
+      enable = true;
+      cpuType = "intel";
+    };
+  };
+
+  boot = {
+    kernelModules = ["kvm-intel" "rtw89"];
+
+    initrd.availableKernelModules = ["xhci_pci" "vmd" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc"];
+  };
+}