about summary refs log tree commit diff stats
path: root/home-manager/soispha/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/soispha/default.nix')
-rw-r--r--home-manager/soispha/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/home-manager/soispha/default.nix b/home-manager/soispha/default.nix
new file mode 100644
index 00000000..10043080
--- /dev/null
+++ b/home-manager/soispha/default.nix
@@ -0,0 +1,35 @@
+{impermanence, ...}: let
+  # TODO actually use this in the user config
+  username = "soispha";
+  homeDirectory = "/home/${username}";
+
+  # xdg
+  configHome = "${homeDirectory}/.config";
+  dataHome = "${homeDirectory}/.local/share";
+  stateHome = "${homeDirectory}/.local/state";
+  cacheHome = "${homeDirectory}/.cache";
+  binHome = "${homeDirectory}/.local/bin";
+  # TODO add XDG_RUNTIME_DIR
+in {
+  imports = [
+    impermanence.nixosModules.home-manager.impermanence
+    ./impermanence
+    ./packages
+    ./config
+    ./wms
+    ./files
+  ];
+
+  # I don't know what this does, but I've seen it a lot online, so it should be good, right?
+  programs.home-manager.enable = true;
+
+  home = {
+    inherit username homeDirectory;
+    stateVersion = "23.05";
+    enableNixpkgsReleaseCheck = true;
+  };
+  xdg = {
+    inherit configHome dataHome stateHome cacheHome; #binHome; # TODO add binHome, when the standart is extended
+    enable = true;
+  };
+}