about summary refs log tree commit diff stats
path: root/home-manager/soispha/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-01 15:31:42 +0200
committerSoispha <soispha@vhack.eu>2023-08-01 15:42:54 +0200
commit0a608bd781dcda40144097b007fac0a0c60a8ee1 (patch)
treee69fbc1fd0e15e3b86f31f47b776df21f6f0170d /home-manager/soispha/default.nix
parentFix(hm/conf/gammastep): Use lighter settings on laptops (diff)
downloadnixos-config-0a608bd781dcda40144097b007fac0a0c60a8ee1.zip
Refactor(treewide): Move module configuration in separate files
Diffstat (limited to 'home-manager/soispha/default.nix')
-rw-r--r--home-manager/soispha/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/home-manager/soispha/default.nix b/home-manager/soispha/default.nix
new file mode 100644
index 00000000..10043080
--- /dev/null
+++ b/home-manager/soispha/default.nix
@@ -0,0 +1,35 @@
+{impermanence, ...}: let
+  # TODO actually use this in the user config
+  username = "soispha";
+  homeDirectory = "/home/${username}";
+
+  # xdg
+  configHome = "${homeDirectory}/.config";
+  dataHome = "${homeDirectory}/.local/share";
+  stateHome = "${homeDirectory}/.local/state";
+  cacheHome = "${homeDirectory}/.cache";
+  binHome = "${homeDirectory}/.local/bin";
+  # TODO add XDG_RUNTIME_DIR
+in {
+  imports = [
+    impermanence.nixosModules.home-manager.impermanence
+    ./impermanence
+    ./packages
+    ./config
+    ./wms
+    ./files
+  ];
+
+  # I don't know what this does, but I've seen it a lot online, so it should be good, right?
+  programs.home-manager.enable = true;
+
+  home = {
+    inherit username homeDirectory;
+    stateVersion = "23.05";
+    enableNixpkgsReleaseCheck = true;
+  };
+  xdg = {
+    inherit configHome dataHome stateHome cacheHome; #binHome; # TODO add binHome, when the standart is extended
+    enable = true;
+  };
+}