about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/plugins/telescope/keymaps/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/plugins/telescope/keymaps/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/plugins/telescope/keymaps/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/plugins/telescope/keymaps/default.nix b/home-manager/soispha/config/neovim/nixvim/plugins/telescope/keymaps/default.nix
index a0ffdd5e..f967a739 100644
--- a/home-manager/soispha/config/neovim/nixvim/plugins/telescope/keymaps/default.nix
+++ b/home-manager/soispha/config/neovim/nixvim/plugins/telescope/keymaps/default.nix
@@ -1,6 +1,9 @@
 {...}: {
   programs.nixvim.plugins.telescope.keymaps = {
-    # TODO add diagnostics and workspace symbols here
+    "<space>rg" = {
+      action = "live_grep";
+      desc = "[rg] in a live session";
+    };
     "<space>gd" = {
       action = "lsp_definitions";
       desc = "[G]oto [D]efinition (Telescope)";