about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/plugins/lsp/keymaps/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/plugins/lsp/keymaps/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/plugins/lsp/keymaps/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/plugins/lsp/keymaps/default.nix b/home-manager/soispha/config/neovim/nixvim/plugins/lsp/keymaps/default.nix
index c36bc102..1cca9866 100644
--- a/home-manager/soispha/config/neovim/nixvim/plugins/lsp/keymaps/default.nix
+++ b/home-manager/soispha/config/neovim/nixvim/plugins/lsp/keymaps/default.nix
@@ -70,6 +70,7 @@
       normal = {
         "<space>f" = {
           action = "function() vim.lsp.buf.format { async = true } end";
+          lua = true;
           desc = "[F]ormat the current buffer (asynchronously)";
         };
         "<space>wl" = {
@@ -78,6 +79,7 @@
               print(vim.inspect(vim.lsp.buf.list_workspace_folders()))
             end
           '';
+          lua = true;
           desc = "[W]orkspace folders [l]ist";
         };
       };