about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixvim/plugins/lf-nvim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/soispha/config/neovim/nixvim/plugins/lf-nvim/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixvim/plugins/lf-nvim/default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/home-manager/soispha/config/neovim/nixvim/plugins/lf-nvim/default.nix b/home-manager/soispha/config/neovim/nixvim/plugins/lf-nvim/default.nix
index a42c6f33..37686779 100644
--- a/home-manager/soispha/config/neovim/nixvim/plugins/lf-nvim/default.nix
+++ b/home-manager/soispha/config/neovim/nixvim/plugins/lf-nvim/default.nix
@@ -1,8 +1,18 @@
-{lib, ...}: {
+{
+  pkgs,
+  lib,
+  ...
+}: {
   programs.nixvim = {
     # TODO package lf-nvim though a module
+    # FIXME change the nvim path, when I change the path with lf
     extraConfigLuaPost = ''
       ${lib.strings.fileContents ./lua/lf-nvim.lua}
     '';
+    extraPlugins = [
+      pkgs.vimExtraPlugins.lf-nvim
+
+      pkgs.vimExtraPlugins.nvim-toggleterm-lua # required by lf-nvim
+    ];
   };
 }