about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixneovim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/soispha/config/neovim/nixneovim/default.nix')
-rw-r--r--home-manager/soispha/config/neovim/nixneovim/default.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/home-manager/soispha/config/neovim/nixneovim/default.nix b/home-manager/soispha/config/neovim/nixneovim/default.nix
new file mode 100644
index 00000000..bd10b36d
--- /dev/null
+++ b/home-manager/soispha/config/neovim/nixneovim/default.nix
@@ -0,0 +1,42 @@
+{
+  lib,
+  pkgs,
+  ...
+}: {
+  imports = [
+    ./options
+    ./mappings
+  ];
+  # TODO package nightfox though a module
+  programs.nixneovim = {
+    enable = true;
+    defaultEditor = true;
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/nightfox.lua}
+    '';
+
+    # to install plugins just activate their modules
+    plugins = {
+      lsp = {
+        enable = true;
+        hls.enable = true;
+        rust-analyzer.enable = true;
+      };
+      treesitter = {
+        enable = true;
+        indent = true;
+      };
+      mini = {
+        enable = true;
+        ai.enable = true;
+        jump.enable = true;
+      };
+    };
+
+    # Not all plugins have own modules
+    # You can add missing plugins here
+    # `pkgs.vimExtraPlugins` is added by the overlay you added at the beginning
+    # For a list of available plugins, look here: [available plugins](https://github.com/jooooscha/nixpkgs-vim-extra-plugins/blob/main/plugins.md)
+    extraPlugins = [pkgs.vimExtraPlugins.nightfox-nvim];
+  };
+}