about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/pkgs/scripts.nix')
-rw-r--r--hm/soispha/pkgs/scripts.nix46
1 files changed, 36 insertions, 10 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index 63a38a34..f97bf50b 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -9,12 +9,21 @@
     name,
     path,
     dependencies,
+    keep_path ? false,
   }:
-    sysLib.writeShellScriptWithLibrary {
-      inherit name;
-      src = ./scripts/${path}/${name};
-      dependencies = dependencies ++ [pkgs.dash];
-    };
+    if keep_path
+    then
+      sysLib.writeShellScriptWithLibraryAndKeepPath {
+        inherit name;
+        src = ./scripts/${path}/${name};
+        dependencies = dependencies ++ [pkgs.dash];
+      }
+    else
+      sysLib.writeShellScriptWithLibrary {
+        inherit name;
+        src = ./scripts/${path}/${name};
+        dependencies = dependencies ++ [pkgs.dash];
+      };
 
   aumo-scr = write_script {
     name = "aumo";
@@ -49,15 +58,31 @@
     path = "small_functions";
     dependencies = builtins.attrValues {inherit (pkgs) glib;};
   };
-  screen_shot-scr = write_script {
-    name = "screen_shot";
+  screenshot_persistent-scr = write_script {
+    name = "screenshot_persistent";
     path = "small_functions";
-    dependencies = builtins.attrValues {inherit (pkgs) grim slurp alacritty;}; # TODO: add llp
+    keep_path = true;
+    dependencies = builtins.attrValues {
+      inherit
+        (pkgs)
+        grim
+        slurp
+        alacritty
+        rofi
+        libnotify
+        lf # TODO: add llp
+        ;
+    };
   };
   mocs-scr = write_script {
     name = "mocs";
     path = "small_functions";
-    dependencies = builtins.attrValues {inherit (pkgs) ncmpc procps;}; # TODO: add mymocp
+    dependencies = [];
+  };
+  screenshot_temporary-scr = write_script {
+    name = "screenshot_temporary";
+    path = "small_functions";
+    dependencies = builtins.attrValues {inherit (pkgs) grim slurp wl-clipboard;};
   };
   neorg-scr = sysLib.writeShellScriptWithLibraryAndKeepPath {
     name = "neorg";
@@ -131,7 +156,8 @@ in [
   # llp-scr # TODO: see above
   mocs-scr
   neorg-scr
-  screen_shot-scr
+  screenshot_persistent-scr
+  screenshot_temporary-scr
   # spodi-scr # # TODO: Reactivate when spotdl builds again <2023-10-31>
   update-sys-scr
   virsh-del-scr