about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/pkgs/scripts.nix')
-rw-r--r--hm/soispha/pkgs/scripts.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index 5bcb82e0..6598880d 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -105,6 +105,22 @@
     };
   };
 
+  git-edit-index-scr = write_shell {
+    name = "git-edit-index";
+    path = "apps";
+    # This starts neovim, wich might want to shell out
+    keepPath = true;
+    dependencies = builtins.attrValues {
+      inherit
+        (pkgs)
+        git
+        gnused
+        # $EDITOR
+
+        ;
+    };
+  };
+
   hibernate-scr = write_shell {
     name = "hibernate";
     path = "wrappers";
@@ -309,6 +325,7 @@ in [
   con2pdf-scr
   description-scr
   fupdate-scr
+  git-edit-index-scr
   hibernate-scr
   ll-scr
   lock-scr