about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/pkgs/scripts.nix')
-rw-r--r--hm/soispha/pkgs/scripts.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index f69bc4cf..7babfae2 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -10,6 +10,7 @@
     path,
     dependencies ? [],
     keep_path ? false,
+    completions ? false,
   }:
     if keep_path
     then
@@ -17,12 +18,14 @@
         inherit name;
         src = ./scripts/${path}/${name};
         dependencies = dependencies ++ [pkgs.dash];
+        generateCompletions = completions;
       }
     else
       sysLib.writeShellScriptWithLibrary {
         inherit name;
         src = ./scripts/${path}/${name};
         dependencies = dependencies ++ [pkgs.dash];
+        generateCompletions = completions;
       };
   write_python = {
     name,
@@ -239,6 +242,7 @@
     name = "yts";
     path = "specific/ytcc";
     keep_path = true; # We need neovim
+    completions = true;
     dependencies = builtins.attrValues {
       inherit (pkgs) ytcc jq gawk ytc;
     };