about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-01-06 21:32:44 +0100
committerSoispha <soispha@vhack.eu>2024-01-06 21:32:44 +0100
commit0b77143e40e43147ee3e9964d84c5e272b5e42fb (patch)
tree911c7d9810a37c52fc98f76d1aef5501abc37fe1 /hm/soispha/pkgs/scripts.nix
parentfeat(hm/pkgs/scr/specific/ytcc/yts): Add cli interface (diff)
downloadnixos-config-0b77143e40e43147ee3e9964d84c5e272b5e42fb.zip
docs(hm/pkgs/scr/specific/ytcc/yts): Add a help text
Diffstat (limited to 'hm/soispha/pkgs/scripts.nix')
-rw-r--r--hm/soispha/pkgs/scripts.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index f69bc4cf..7babfae2 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -10,6 +10,7 @@
     path,
     dependencies ? [],
     keep_path ? false,
+    completions ? false,
   }:
     if keep_path
     then
@@ -17,12 +18,14 @@
         inherit name;
         src = ./scripts/${path}/${name};
         dependencies = dependencies ++ [pkgs.dash];
+        generateCompletions = completions;
       }
     else
       sysLib.writeShellScriptWithLibrary {
         inherit name;
         src = ./scripts/${path}/${name};
         dependencies = dependencies ++ [pkgs.dash];
+        generateCompletions = completions;
       };
   write_python = {
     name,
@@ -239,6 +242,7 @@
     name = "yts";
     path = "specific/ytcc";
     keep_path = true; # We need neovim
+    completions = true;
     dependencies = builtins.attrValues {
       inherit (pkgs) ytcc jq gawk ytc;
     };