about summary refs log tree commit diff stats
path: root/hm/soispha/impermanence/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/impermanence/default.nix')
-rw-r--r--hm/soispha/impermanence/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/hm/soispha/impermanence/default.nix b/hm/soispha/impermanence/default.nix
new file mode 100644
index 00000000..d0cd1ff1
--- /dev/null
+++ b/hm/soispha/impermanence/default.nix
@@ -0,0 +1,31 @@
+{
+  lib,
+  nixosConfig,
+  ...
+}: {
+  config = lib.mkIf nixosConfig.soispha.impermanence.enable {
+    home.persistence."/srv/home/soispha" = {
+      allowOther = true;
+      directories = [
+        ".local/share"
+
+        ".local/state/nvim"
+        ".local/state/wireplumber"
+
+        ".config/Signal"
+        ".config/Element"
+        ".config/iamb/profiles"
+
+        ".cache"
+        ".mozilla"
+
+        "media"
+        "repos"
+        "school"
+      ];
+      files = [
+        ".local/state/lesshst"
+      ];
+    };
+  };
+}