about summary refs log tree commit diff stats
path: root/hm/soispha/files/wallpaper/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/files/wallpaper/default.nix')
-rw-r--r--hm/soispha/files/wallpaper/default.nix14
1 files changed, 10 insertions, 4 deletions
diff --git a/hm/soispha/files/wallpaper/default.nix b/hm/soispha/files/wallpaper/default.nix
index 2c9b3368..119df225 100644
--- a/hm/soispha/files/wallpaper/default.nix
+++ b/hm/soispha/files/wallpaper/default.nix
@@ -1,8 +1,14 @@
 {config, ...}: {
-  home.file = {
-    wallpaper = {
-      source = ./abstract-nord.png;
-      target = "media/pictures/wallpaper";
+  home = {
+    sessionVariables = {
+      WALLPAPER = "${config.home.homeDirectory}/media/pictures/wallpaper";
+    };
+
+    file = {
+      wallpaper = {
+        source = ./abstract-nord.png;
+        target = "media/pictures/wallpaper";
+      };
     };
   };
 }