about summary refs log tree commit diff stats
path: root/hm/soispha/conf/python/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/python/default.nix')
-rw-r--r--hm/soispha/conf/python/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/hm/soispha/conf/python/default.nix b/hm/soispha/conf/python/default.nix
index eeaccdcf..93a530c7 100644
--- a/hm/soispha/conf/python/default.nix
+++ b/hm/soispha/conf/python/default.nix
@@ -1,7 +1,6 @@
-{
-  config,
-  pkgs,
-  ...
-}: {
+{config, ...}: {
   xdg.configFile."python/pythonrc".source = ./pythonrc;
+  environment.sessionVariables = {
+    "PYTHONSTARTUP" = "${config.xdg.configHome}/python/pythonrc";
+  };
 }