about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plugins/telescope/extensions/frecency/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plugins/telescope/extensions/frecency/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plugins/telescope/extensions/frecency/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/plugins/telescope/extensions/frecency/default.nix b/hm/soispha/conf/nvim/plugins/telescope/extensions/frecency/default.nix
new file mode 100644
index 00000000..4a4c22be
--- /dev/null
+++ b/hm/soispha/conf/nvim/plugins/telescope/extensions/frecency/default.nix
@@ -0,0 +1,22 @@
+{...}: {
+  programs.nixvim = {
+    maps = {
+      normal = {
+        "gff" = {
+          action = "function() require('telescope').extensions.frecency.frecency() end";
+          lua = true;
+          desc = "activate the frecency file selection";
+        };
+      };
+    };
+    plugins.telescope = {
+      extensions.frecency = {
+        enable = true;
+        showUnindexed = true;
+        showScores = true;
+        # TODO: add this:
+        #db_safe_mode = true;
+      };
+    };
+  };
+}