about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plugins/lf-nvim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plugins/lf-nvim/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plugins/lf-nvim/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/plugins/lf-nvim/default.nix b/hm/soispha/conf/nvim/plugins/lf-nvim/default.nix
new file mode 100644
index 00000000..c562f400
--- /dev/null
+++ b/hm/soispha/conf/nvim/plugins/lf-nvim/default.nix
@@ -0,0 +1,18 @@
+{
+  pkgs,
+  lib,
+  ...
+}: {
+  programs.nixvim = {
+    # TODO: package lf-nvim though a module
+    # FIXME: change the nvim path, when I change the path with lf
+    extraConfigLuaPost = ''
+      ${lib.strings.fileContents ./lua/lf-nvim.lua}
+    '';
+    extraPlugins = [
+      pkgs.vimExtraPlugins.lf-nvim
+
+      pkgs.vimExtraPlugins.nvim-toggleterm-lua # required by lf-nvim
+    ];
+  };
+}