about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plugins/leap/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plugins/leap/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plugins/leap/default.nix58
1 files changed, 0 insertions, 58 deletions
diff --git a/hm/soispha/conf/nvim/plugins/leap/default.nix b/hm/soispha/conf/nvim/plugins/leap/default.nix
deleted file mode 100644
index bffdf33c..00000000
--- a/hm/soispha/conf/nvim/plugins/leap/default.nix
+++ /dev/null
@@ -1,58 +0,0 @@
-{...}: {
-  programs.nixvim = {
-    plugins.leap = {
-      enable = true;
-      addDefaultMappings = false; # They don't work with dvorak.
-      safeLabels = [
-        "f"
-        "j"
-        "k"
-        "l"
-        "/"
-        "z"
-        "S"
-        "F"
-        "J"
-        "K"
-        "L"
-        "H"
-        "W"
-        "E"
-        "M"
-        "B"
-        "U"
-        "X"
-        "?"
-        "Z"
-      ];
-    };
-    maps = {
-      normalVisualOp = {
-        "m" = {
-          action = "<Plug>(leap-forward-to)";
-          desc = "leap forward to";
-        };
-        "M" = {
-          action = "<Plug>(leap-backward-to)";
-          desc = "leap backward to";
-        };
-        "gs" = {
-          action = "<Plug>(leap-from-window)";
-          desc = "leap to enterable windows";
-        };
-      };
-      visual = {
-        /*
-        "x" = {
-          action = "<Plug>(leap-forward-till)";
-          desc = "leap forward till";
-        };
-        "X" = {
-          action = "<Plug>(leap-backward-till)";
-          desc = "leap backward till";
-        };
-        */
-      };
-    };
-  };
-}