about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plugins/femaco/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plugins/femaco/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plugins/femaco/default.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/hm/soispha/conf/nvim/plugins/femaco/default.nix b/hm/soispha/conf/nvim/plugins/femaco/default.nix
deleted file mode 100644
index 570ff297..00000000
--- a/hm/soispha/conf/nvim/plugins/femaco/default.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{
-  pkgs,
-  lib,
-  ...
-}: {
-  programs.nixvim = {
-    # TODO: package femaco through a module
-    extraConfigLuaPost = ''
-      ${lib.strings.fileContents ./lua/femaco.lua}
-    '';
-    extraPlugins = [
-      pkgs.vimExtraPlugins.nvim-FeMaco-lua
-    ];
-    maps = {
-      normal = {
-        "<leader>cc" = {
-          action = "require('femaco.edit').edit_code_block";
-          lua = true;
-          desc = "edit a [c]ode blo[c]k with femaco";
-        };
-      };
-    };
-  };
-}