about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix b/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
index 12c9736c..946d32f1 100644
--- a/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
+++ b/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
@@ -4,10 +4,12 @@
     extraPlugins = [
       pkgs.vimExtraPlugins.telescope-bibtex-nvim
     ];
-    maps.normal = {
-      "<space>ib" = {
-        desc = "[i]nsert a [b]atex citation";
-      };
-    };
+    keymaps = [
+      {
+        key = "<space>ib";
+        mode = "n";
+        options.desc = "[i]nsert a [b]atex citation";
+      }
+    ];
   };
 }