about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix b/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
new file mode 100644
index 00000000..12c9736c
--- /dev/null
+++ b/hm/soispha/conf/nvim/plgs/telescope/extensions/bibtex/default.nix
@@ -0,0 +1,13 @@
+{pkgs, ...}: {
+  # WARNING: This is only activated in tex files via the ftplugin.
+  programs.nixvim = {
+    extraPlugins = [
+      pkgs.vimExtraPlugins.telescope-bibtex-nvim
+    ];
+    maps.normal = {
+      "<space>ib" = {
+        desc = "[i]nsert a [b]atex citation";
+      };
+    };
+  };
+}