about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plgs/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plgs/default.nix57
1 files changed, 31 insertions, 26 deletions
diff --git a/hm/soispha/conf/nvim/plgs/default.nix b/hm/soispha/conf/nvim/plgs/default.nix
index c3c36da0..4f1f2172 100644
--- a/hm/soispha/conf/nvim/plgs/default.nix
+++ b/hm/soispha/conf/nvim/plgs/default.nix
@@ -1,28 +1,33 @@
 {...}: {
-  imports = [
-    ./colorscheme
-    ./comment-nvim
-    ./debugprint
-    ./femaco
-    ./flatten-nvim
-    ./goto-preview
-    ./harpoon
-    ./leap
-    ./lf-nvim
-    ./lsp
-    #./lsp-progress-nvim
-    ./lspkind
-    ./ltex_extra
-    ./lualine
-    ./luasnip
-    ./neorg
-    ./nvim-cmp
-    ./nvim-lint
-    ./raw_plugins
-    ./telescope
-    ./todo-comments
-    ./treesitter
-    ./vim-tex
-    ./which-key
-  ];
+  imports =
+    [
+      # Plugins not yet packaged in nixpkgs
+      ./debugprint
+      ./lf-nvim
+      # ./lsp-progress-nvim
+    ]
+    ++ [
+      # Already packaged in nixpkgs
+      ./colorscheme
+      ./comment-nvim
+      ./femaco
+      ./flatten-nvim
+      ./goto-preview
+      ./harpoon
+      ./leap
+      ./lsp
+      ./lspkind
+      ./ltex_extra
+      ./lualine
+      ./luasnip
+      ./neorg
+      ./nvim-cmp
+      ./nvim-lint
+      ./raw_plugins
+      ./telescope
+      ./todo-comments
+      ./treesitter
+      ./vim-tex
+      ./which-key
+    ];
 }