about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/debugprint/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/plgs/debugprint/default.nix')
-rw-r--r--hm/soispha/conf/nvim/plgs/debugprint/default.nix74
1 files changed, 0 insertions, 74 deletions
diff --git a/hm/soispha/conf/nvim/plgs/debugprint/default.nix b/hm/soispha/conf/nvim/plgs/debugprint/default.nix
deleted file mode 100644
index b0d72339..00000000
--- a/hm/soispha/conf/nvim/plgs/debugprint/default.nix
+++ /dev/null
@@ -1,74 +0,0 @@
-{
-  pkgs,
-  lib,
-  ...
-}: {
-  programs.nixvim = {
-    # TODO: package debugprint though a module
-    extraConfigLuaPost = ''
-      ${lib.strings.fileContents ./lua/debugprint.lua}
-    '';
-    extraPlugins = [
-      pkgs.vimExtraPlugins.debugprint-nvim
-    ];
-
-    keymaps = [
-      {
-        key = "g?v";
-        mode = ["v" "n"];
-        action = ''
-          function()
-            return require('debugprint').debugprint({variable = true;});
-          end
-        '';
-        lua = true;
-        options.expr = true;
-        options.desc = ''
-          'variable' debug line below the current line
-        '';
-      }
-      {
-        key = "g?V";
-        mode = ["v" "n"];
-        action = ''
-          function()
-            return require('debugprint').debugprint({above = true; variable = true;}) ;
-          end
-        '';
-        lua = true;
-        options.expr = true;
-        options.desc = ''
-          'variable' debug line above the current line
-        '';
-      }
-      {
-        key = "g?p";
-        mode = "n";
-        action = ''
-          function()
-            return require('debugprint').debugprint();
-          end
-        '';
-        lua = true;
-        options.expr = true;
-        options.desc = ''
-          'plain' debug line below the current line
-        '';
-      }
-      {
-        key = "g?P";
-        mode = "n";
-        action = ''
-          function()
-            return require('debugprint').debugprint({above = true;});
-          end
-        '';
-        lua = true;
-        options.expr = true;
-        options.desc = ''
-          'plain' debug line above the current line
-        '';
-      }
-    ];
-  };
-}