about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/default.nix')
-rw-r--r--hm/soispha/conf/nvim/default.nix30
1 files changed, 18 insertions, 12 deletions
diff --git a/hm/soispha/conf/nvim/default.nix b/hm/soispha/conf/nvim/default.nix
index d01f85a4..8c04ae9d 100644
--- a/hm/soispha/conf/nvim/default.nix
+++ b/hm/soispha/conf/nvim/default.nix
@@ -15,18 +15,24 @@
     enable = true;
 
     # source: https://www.patorjk.com/software/taag/#p=display&f=ANSI%20Shadow&t=Neovim
-    extraConfigLuaPre = lib.mkBefore ''
-      ---------------------------------------------------------------------------
-      --
-      --     ███╗   ██╗███████╗ ██████╗ ██╗   ██╗██╗███╗   ███╗
-      --     ████╗  ██║██╔════╝██╔═══██╗██║   ██║██║████╗ ████║
-      --     ██╔██╗ ██║█████╗  ██║   ██║██║   ██║██║██╔████╔██║
-      --     ██║╚██╗██║██╔══╝  ██║   ██║╚██╗ ██╔╝██║██║╚██╔╝██║
-      --     ██║ ╚████║███████╗╚██████╔╝ ╚████╔╝ ██║██║ ╚═╝ ██║
-      --     ╚═╝  ╚═══╝╚══════╝ ╚═════╝   ╚═══╝  ╚═╝╚═╝     ╚═╝
-      --
-      ---------------------------------------------------------------------------
-    '';
+    extraConfigLuaPre =
+      /*
+       FIXME: Update the merge function to support that: <2023-08-29>
+
+      lib.mkBefore
+      */
+      ''
+        ---------------------------------------------------------------------------
+        --
+        --     ███╗   ██╗███████╗ ██████╗ ██╗   ██╗██╗███╗   ███╗
+        --     ████╗  ██║██╔════╝██╔═══██╗██║   ██║██║████╗ ████║
+        --     ██╔██╗ ██║█████╗  ██║   ██║██║   ██║██║██╔████╔██║
+        --     ██║╚██╗██║██╔══╝  ██║   ██║╚██╗ ██╔╝██║██║╚██╔╝██║
+        --     ██║ ╚████║███████╗╚██████╔╝ ╚████╔╝ ██║██║ ╚═╝ ██║
+        --     ╚═╝  ╚═══╝╚══════╝ ╚═════╝   ╚═══╝  ╚═╝╚═╝     ╚═╝
+        --
+        ---------------------------------------------------------------------------
+      '';
 
     extraPackages = with pkgs; [
       /*