about summary refs log tree commit diff stats
path: root/hm/soispha/conf/alacritty/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/alacritty/default.nix')
-rw-r--r--hm/soispha/conf/alacritty/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/hm/soispha/conf/alacritty/default.nix b/hm/soispha/conf/alacritty/default.nix
index 7c23c919..d06f03b8 100644
--- a/hm/soispha/conf/alacritty/default.nix
+++ b/hm/soispha/conf/alacritty/default.nix
@@ -1,7 +1,22 @@
 {lib, ...}: let
+  # NOTE: The `colorscheme.yml` import __needs__ to be __after__ the `colors.yml` import, otherwise, applying it wont
+  # work. <2023-08-28>
   config_file = ''
     ${lib.strings.fileContents ./yaml/base.yml}
+    ${lib.strings.fileContents ./yaml/bell.yml}
+    ${lib.strings.fileContents ./yaml/colors.yml}
     ${lib.strings.fileContents ./yaml/colorscheme.yml}
+    ${lib.strings.fileContents ./yaml/cursor.yml}
+    ${lib.strings.fileContents ./yaml/debug.yml}
+    ${lib.strings.fileContents ./yaml/env.yml}
+    ${lib.strings.fileContents ./yaml/font.yml}
+    ${lib.strings.fileContents ./yaml/key_bindings.yml}
+    ${lib.strings.fileContents ./yaml/mouse.yml}
+    ${lib.strings.fileContents ./yaml/mouse_bindings.yml}
+    ${lib.strings.fileContents ./yaml/scrolling.yml}
+    ${lib.strings.fileContents ./yaml/selection.yml}
+    ${lib.strings.fileContents ./yaml/shell.yml}
+    ${lib.strings.fileContents ./yaml/window.yml}
   '';
 in {
   programs.alacritty = {