about summary refs log tree commit diff stats
path: root/flake/packages/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake/packages/default.nix')
-rw-r--r--flake/packages/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/flake/packages/default.nix b/flake/packages/default.nix
index a8fc2d64..95aa539a 100644
--- a/flake/packages/default.nix
+++ b/flake/packages/default.nix
@@ -5,7 +5,6 @@
   myPkgs,
   pkgsStable,
   sysLib,
-  nixVim,
   system,
   shell_library,
   ...
@@ -23,7 +22,10 @@
         # NOTE: This is copied from `nixvim`, and could be achieved by setting
         # `config.wrapRc` to `true`. But I have yet to find a way to set this in this
         # context, but not in the general context.  <2024-11-09>
-        wrapped = config.build.package.override (prev: {
+        # NOTE: I'm not sure why we need `nvimPackage` instead of just the `package`
+        # attribute here, but the bare `package` attribute does not provide a `override`
+        # function. <2025-02-02>
+        wrapped = config.build.nvimPackage.override (prev: {
           wrapperArgs =
             (
               if lib.isString prev.wrapperArgs
@@ -64,8 +66,6 @@
             value)
         myPkgs
       )));
-
-  firefox = (import ../../modules/home.legacy/conf/firefox/scripts) {inherit pkgs sysLib;};
 in
   {
     # install-iso = nixos-generators.nixosGenerate {
@@ -94,5 +94,4 @@ in
   }
   // output
   // output_neovim
-  // firefox
   // myPkgsFlat